溫馨提示×

您好,登錄后才能下訂單哦!

密碼登錄×
登錄注冊(cè)×
其他方式登錄
點(diǎn)擊 登錄注冊(cè) 即表示同意《億速云用戶服務(wù)條款》

Minimum Transport Cost (floyd算法)

發(fā)布時(shí)間:2020-06-29 03:01:07 來(lái)源:網(wǎng)絡(luò) 閱讀:410 作者:DawnNext 欄目:web開(kāi)發(fā)

Minimum Transport Cost  Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 
 

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 
 

Output

From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 
 

Sample Input

5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output

From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
# include <stdio.h>
# include <stdlib.h>
#define INF 1 << 20
int dis[10005];
int p[10005][1005];
int map[10005][10005];
int mag[10005];
int n;
void floyd()
{
    int i,j,k;
    for(k=1; k<=n; k++)
    {
        for(i=1;i<=n;i++)
        {
            if( i == k || map[i][k]==-1 ) continue;
            for(j=1;j<=n;j++)
            {
                if( k == j || i == j || map[k][j] == -1 ) continue;
                int t = map[i][k] + map[k][j] + mag[k];
                if(map[i][j] == -1 || map[i][j] > t)
                {
                    map[i][j] = t;
                    p[i][j] = p[i][k];
                }
                else if(map[i][j]==t && p[i][k]<p[i][j])
                {
                    p[i][j]=p[i][k];
                }
            }
        }
    }
}
void pr(int x,int y)
{
 	 printf("Path: %d",x);
    while(p[x][y]!=y)
    {
        printf("-->%d",p[x][y]);
        x=p[x][y];
    }
    printf("-->%d\n",y);
}
int main()
{
 	int kai,jie;
 	while(scanf("%d",&n)!=EOF&&n!=0)
	{
         for(int i=1;i<=n;i++)
		    for(int j=1;j<=n;j++)
		    	{
				 	scanf("%d",&map[i][j]);
				 	p[i][j]=j;	
                }
		 for(int i=1;i<=n;i++)
		 	scanf("%d",&mag[i]);
		 floyd();    		
	     while(scanf("%d%d",&kai,&jie)!=EOF&&kai!=-1&&jie!=-1)
  	     {
		 	 printf("From %d to %d :\n",kai,jie);
             if(kai!=jie)
     	   	 {	 
		 	 		 pr(kai,jie);
		 	 		 printf("Total cost : ");
		 	 		 printf("%d\n",map[kai][jie]);
 			 		 printf("\n");
			 }
			 else 	
			 {
			  		printf("Path: %d\n",kai);
			  		printf("Total cost : ");
	 	 		 	printf("0\n");
 		 			printf("\n");
			 }
		 }		 
    }	
}
向AI問(wèn)一下細(xì)節(jié)

免責(zé)聲明:本站發(fā)布的內(nèi)容(圖片、視頻和文字)以原創(chuàng)、轉(zhuǎn)載和分享為主,文章觀點(diǎn)不代表本網(wǎng)站立場(chǎng),如果涉及侵權(quán)請(qǐng)聯(lián)系站長(zhǎng)郵箱:is@yisu.com進(jìn)行舉報(bào),并提供相關(guān)證據(jù),一經(jīng)查實(shí),將立刻刪除涉嫌侵權(quán)內(nèi)容。

AI