溫馨提示×

您好,登錄后才能下訂單哦!

密碼登錄×
登錄注冊(cè)×
其他方式登錄
點(diǎn)擊 登錄注冊(cè) 即表示同意《億速云用戶服務(wù)條款》

【Uva 129】Krypton Factor(困難的串)

發(fā)布時(shí)間:2020-08-27 19:29:30 來源:網(wǎng)絡(luò) 閱讀:438 作者:Rign 欄目:編程語言

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants
have very high mental and physical abilities. In one section of the contest the contestants are tested on
their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many
of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to
this test, the organisers have decided that sequences containing certain types of repeated subsequences
should not be used. However, they do not wish to remove all subsequences that are repeated, since in
that case no single character could be repeated. This in itself would make the problem too easy for the
contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining
identical subsequences. Sequences containing such an occurrence will be called “easy”. Other sequences
will be called “hard”.
For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the
subsequence CB. Other examples of easy sequences are:
? BB
? ABCDACABCAB
? ABCDABCD
Some examples of hard sequences are:
? D
? DC
? ABDAB
? CBABCBA
In order to provide the Quiz Master with a potentially unlimited source of questions you are asked
to write a program that will read input lines from standard input and will write to standard output.
Input
Each input line contains integers n and L (in that order), where n > 0 and L is in the range 1 ≤ L ≤ 26.
Input is terminated by a line containing two zeroes.
Output
For each input line prints out the n-th hard sequence (composed of letters drawn from the first L letters
in the alphabet), in increasing alphabetical order (Alphabetical ordering here corresponds to the normal
ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The
first sequence in this ordering is ‘A’. You may assume that for given n and L there do exist at least n
hard sequences.
As such a sequence is potentially very long, split it into groups of four (4) characters separated by
a space. If there are more than 16 such groups, please start a new line for the 17th group.
Your program may assume a maximum sequence length of 80.
For example, with L = 3, the first 7 hard sequences are:
A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA
Sample Input
7 3
30 3
0 0
Sample Output
ABAC ABA
7
ABAC ABCA CBAB CABA CABC ACBA CABA
28

大致的題意:就是你要輸入一個(gè)n和L,分別代表前L個(gè)字母輸出第n個(gè)小的困難的串,而困難的串就是其中沒有連續(xù)重復(fù)的字符串

利用的方法就是回溯法

#include<bits/stdc++.h>
using namespace std;
int S[100],cnt;
int n,L;

int dfs(int cur){
    //輸出當(dāng)前的hard sequence
    //判斷的條件是cnt為n 也就是第n個(gè)小的hard sequence
    if(cnt++==n){
        //cur是當(dāng)前坐標(biāo)長度
        for(int i=0;i<cur;i++){
            //注意格式
            printf("%c",'A'+S[i]);
            if(i%64==63 && i!=cur-1) printf("\n");
            else if(i%4==3 && i!=cur-1) printf(" ");

        }
        //輸出長度
        printf("\n%d\n",cur);
        return 0;
    }
    //接下來的內(nèi)容就是判斷當(dāng)前字符串是不是hard sequence
    for(int i=0;i<L;i++){
        S[cur]=i;
        int ok=1;
        for(int j=1;j*2<=cur+1;j++){ //后綴長度為j a(bcd)(bcd)
            //內(nèi)循環(huán)檢查 flag為equal
            //外循環(huán)檢查 flag為 ok
            int equal=1;
            for(int k=0;k<j;k++) if(S[cur-k]!=S[cur-k-j]) {equal=0;break;}
            if(equal) {ok=0;break;}
        }
        if(ok) if(!dfs(cur+1)) return 0;
    }
    return 1;
}

int main(){
    while(cin>>n>>L && (n!=0 && L!=0)){
        cnt=0;
        dfs(0);
    }
    return 0;
}
向AI問一下細(xì)節(jié)

免責(zé)聲明:本站發(fā)布的內(nèi)容(圖片、視頻和文字)以原創(chuàng)、轉(zhuǎn)載和分享為主,文章觀點(diǎn)不代表本網(wǎng)站立場(chǎng),如果涉及侵權(quán)請(qǐng)聯(lián)系站長郵箱:is@yisu.com進(jìn)行舉報(bào),并提供相關(guān)證據(jù),一經(jīng)查實(shí),將立刻刪除涉嫌侵權(quán)內(nèi)容。

AI